청호PENTEST - Professional Penetration Testing Company

Select Language
조회 수 : 1119
2012.12.13 (12:14:48)

개요

  • 국내 PHP기반의 공개 웹 게시판인 그누보드에서 XSS 취약점이 발견됨
  • 취약한 버전을 사용하고 있을 경우, 홈페이지 해킹에 의한 계정 탈취 등의 피해를 입을 수 있으므로
  • 웹 관리자의 적극적인 조치 필요

해당시스템

  • 영향 받는 소프트웨어
    - 그누보드 4.36.10 및 이전 버전

해결방안

  • 기존 그누보드 사용자는 업데이트가 적용된 상위 버전으로 업그레이드 [1]
    ※ 패치 작업 이전에 원본 파일은 백업 필요
  • 그누보드를 새로 설치하는 이용자
    - 반드시 보안패치가 적용된 최신버전(4.36.11 이상)을 설치

용어 정리

  • PHP : 동적인 웹사이트를 위한 서버 측 스크립트 언어
  • XSS (Cross Site Scripting) : 게시물에 실행 코드와 태그의 업로드가 규제되지 않는 경우 이를 악용하여 열람한 타 사용자에게 악성 스크립트를 실행 시킬 수 있는 취약점
  • 그누보드 : PHP언어로 작성된 홈페이지용 게시판 소프트웨어 또는 프레임 워크

문의사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

기타

  • 본 취약점은 Krcert 홈페이지를 통해 UN Security 팀에서 제공해주셨습니다. 

[참고사이트] 

[1] http://sir.co.kr/bbs/board.php?bo_table=g4_pds&wr_id=8189&page=1




원문출처 : http://www.krcert.or.kr/kor/data/secNoticeView.jsp?p_bulletin_writing_sequence=1715
Tag List

서비스 링크

X
Login

브라우저를 닫더라도 로그인이 계속 유지될 수 있습니다. 로그인 유지 기능을 사용할 경우 다음 접속부터는 로그인을 하실 필요가 없습니다. 단, 게임방, 학교 등 공공장소에서 이용 시 개인정보가 유출될 수 있으니 꼭 로그아웃을 해주세요.

아이디가 없으신 분은

회원가입 후 이용하실 수 있습니다.

X