청호PENTEST - Professional Penetration Testing Company

Select Language
조회 수 : 586
2012.11.14 (11:04:56)

[MS12-071] Internet Explorer 에서 발생하는 취약점으로 인한 원격코드 실행 문제

 

영향

  • 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

설명

  • 사용자가 Internet Explorer를 이용하여 특수하게 제작된 웹페이지를 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재
  • 관련취약점 :
    - CFormElement Use After Free Vulnerability (CVE-2012-1538)
    - CTreePos Use After Free Vulnerability (CVE-2012-1539)
    - CTreeNode Use After Free Vulnerability (CVE-2012-4775)
  • 영향 : 원격코드 실행
  • 중요도 : 긴급

해당시스템

  • 영향 받는 소프트웨어

    Windows Vista 서비스 팩2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows 7 서비스 팩0, 1

    Windows 7 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 64-bit 서비스 팩0, 1

    Internet Explorer 9

  • 영향받지 않은 소프트웨어

    Windows XP 서비스 팩3

    Windows XP Professional 64-bit 서비스 팩2

    Windows Server 2003 서비스 팩2

    Windows Server 2003 64-bit 서비스 팩2

    Windows Server 2003 Itanium 서비스 팩2

    Internet Explorer 6

    Internet Explorer 7

    Internet Explorer 8

    Windows Vista 서비스 팩2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows Server 2008 Itanium 서비스 팩2

    Internet Explorer 7

    Internet Explorer 8

    Windows 7 서비스 팩0, 1

    Windows 7 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 Itanium 서비스 팩0, 1

    Internet Explorer 8

    Windows 8

    Windows 8 64-bit

    Windows Sever 2012

    Windows RT

    Internet Explorer 10

    Windows Server 2008 서버코어(Server Core)설치

    Windows Server 2008 64-bit 서버코어(Server Core)설치

    Windows Server 2008 R2 서버코어(Server Core)설치

    Windows Server 2008 R2 64-bit 서버코어(Server Core)설치

    Windows Server 2012 서버코어(Server Core)설치

     

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트

 

[MS12-072] Windows Shell 에서 발생하는 취약점으로 인한 원격코드 실행 문제

 

영향

  • 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

설명

  • 사용자가 특수하게 제작된 서류가방을 탐색할 경우, 원격코드가 실행될 수 있는 취약점이 존재
  • 관련취약점 :
    - Windows Briefcase Integer Underflow Vulnerability (CVE-2012-1527)
    - Windows Briefcase Integer Overflow Vulnerability (CVE-2012-1528)
  • 영향 : 원격코드 실행
  • 중요도 : 긴급

해당시스템

  • 영향 받는 소프트웨어
    - Windows XP 서비스 팩3
    - Windows XP Professional 64-bit 서비스 팩2
    - Windows Server 2003 서비스 팩2
    - Windows Server 2003 64-bit 서비스 팩2
    - Windows Server 2003 Itanium 서비스 팩2
    - Windows Vista 서비스 팩2
    - Windows Vista 64-bit 서비스 팩2
    - Windows Server 2008 서비스 팩2
    - Windows Server 2008 64-bit 서비스 팩2
    - Windows 7 서비스 팩0, 1
    - Windows 7 64-bit 서비스 팩0, 1
    - Windows Server 2008 R2 64-bit 서비스 팩0, 1
    - Windows 8
    - Windows 8 64-bit
    - Windows Sever 2012
  • 영향 받지 않는 소프트웨어
    - Windows Server 2008 Itanium 서비스 팩2 
    - Windows Server 2008 R2 Itanium 서비스 팩0, 1

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트

 

[MS12-073] IIS(Internet Information Services)에서 발생하는 취약점으로 인한 정보유출 문제

 

영향

  • 공격자가 영향 받는 시스템에 대한 정보유출

설명

  • 공격자가 특수하게 제작된 FTP명령어를 전송할 경우, 정보유출이 발생할 수 있는 취약점이 존재
  • 관련취약점 :
    - Password Disclosure Vulnerability (CVE-2012-2531)
    - FTP Command Injection Vulnerability (CVE-2012-2532)
  • 영향 : 권한상승
  • 중요도 : 중요

해당시스템

  • 영향 받는 소프트웨어

    Windows Vista 서비스 팩2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows Server 2008 서버코어(Server Core)설치

    Windows Server 2008 64-bit 서버코어(Server Core)설치

    IIS 7.0 - FTP Service 7.0, 7.5

    Windows 7 서비스 팩0, 1

    Windows 7 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 Itanium 서비스 팩0, 1

    Windows Server 2008 R2 서버코어(Server Core)설치

    Windows Server 2008 R2 64-bit 서버코어(Server Core)설치

    IIS 7.5 - FTP Service 7.5

  • 영향 받지 않는 소프트웨어

    Windows XP 서비스 팩3

    IIS 5.1 - FTP Service 5.1

    Windows XP Professional 64-bit 서비스 팩2

    Windows Server 2003 서비스 팩2

    Windows Server 2003 64-bit 서비스 팩2

    Windows Server 2003 Itanium 서비스 팩2

    IIS 6.0 - FTP Service 6.0

    Windows Vista 서비스 팩2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows Server 2008 Itanium 서비스 팩2

    IIS 7.0 - FTP Service 6.0

    IIS 7.5 - FTP Service 6.0

    Windows 8

    Windows 8 64-bit

    Windows Sever 2012

    IIS 8.0

    Windows RT

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트

 

[MS12-074] .NET Framework 에서 발생하는 취약점으로 인한 원격코드 실행 문제

 

영향

  • 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

설명

  • 공격자는 사용자에게 악의적인 프록시 자동설정 파일을 사용하도록 유도하여, 실행중인 프로그램에 코드를 삽입시켜 원격코드가 실행될 수 있는 취약점이 존재
  • 관련취약점 :
     - Reflection Bypass Vulnerability (CVE-2012-1895)
     - Code Access Security Info Disclosure Vulnerability (CVE-2012-1896)
     - .NET Framework Insecure Library Loading Vulnerability (CVE-2012-2519)
     - Web Proxy Auto-Discovery Vulnerability (CVE-2012-4776)
     - WPF Reflection Optimization Vulnerability (CVE-2012-4777)
  • 영향 : 원격코드 실행
  • 중요도 : 긴급

해당시스템

  • 영향 받는 소프트웨어

    Windows XP 서비스 팩3

    Microsoft .NET Framework 1.0 서비스 팩3

    Microsoft .NET Framework 1.1 서비스 팩1

    Microsoft .NET Framework 2.0 서비스 팩2

    Microsoft .NET Framework 4

    Windows XP Professional 64-bit 서비스 팩2

    Windows Server 2003 서비스 팩2

    Windows Server 2003 64-bit 서비스 팩2

    Windows Server 2003 서비스 팩2 Itanium

    Windows Vista 서비스 팩 2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows Server 2008 Itanium 서비스 팩2

    Microsoft .NET Framework 1.1 서비스 팩1

    Microsoft .NET Framework 2.0 서비스 팩2

    Microsoft .NET Framework 4

    Windows 7 서비스 팩0, 1

    Windows 7 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 64-bit 서비스 팩0, 1

    Windows Server 2008 R2 Itanium 서비스 팩0, 1

    Microsoft .NET Framework 3.5.1

    Microsoft .NET Framework 4

    Windows Vista 서비스 팩 2

    Windows Vista 64-bit 서비스 팩2

    Windows Server 2008 서비스 팩2

    Windows Server 2008 64-bit 서비스 팩2

    Windows 7 서비스 팩1

    Windows 7 64-bit 서비스 팩1

    Windows Server 2008 R2 64-bit 서비스 팩1

    Windows RT

    Microsoft .NET Framework 4.5

    Windows 8

    Windows Sever 2012

    Microsoft .NET Framework 3.5

    Microsoft .NET Framework 4.5

  • 영향 받지 않는 소프트웨어
    - Microsoft .NET Framework 3.0 서비스 팩2
    - Microsoft .NET Framework 3.5 서비스 팩1

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트

 

[MS12-075] Windows 커널 모드 드라이버에서 발생하는 취약점으로 인한 원격코드 실행 문제

 

영향

  • 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

설명

  • 사용자가 특수하게 제작된 문서를 열람하거나 트루타입폰트가 포함된 악성 웹페이지를 방문할 경우, 원격코드가 실행될 수 있는 취약점이 존재
  • 관련취약점 :
    - Win32k Use After Free Vulnerability – (CVE-2012-2530)
    - Win32k Use After Free Vulnerability – (CVE-2012-2553)
    - TrueType Font Parsing Vulnerability – (CVE-2012-2897)
  • 영향 : 원격코드 실행
  • 중요도 : 긴급

해당시스템

  • 영향 받는 소프트웨어
    - Windows XP 서비스 팩3
    - Windows XP Professional 64-bit 서비스 팩2
    - Windows Server 2003 서비스 팩2
    - Windows Server 2003 64-bit 서비스 팩2
    - Windows Server 2003 Itanium 서비스 팩2
    - Windows Vista 서비스 팩2
    - Windows Vista 64-bit 서비스 팩2
    - Windows Server 2008 서비스 팩2
    - Windows Server 2008 64-bit 서비스 팩2
    - Windows Server 2008 Itanium 서비스 팩2
    - Windows 7 서비스 팩0, 1
    - Windows 7 64-bit 서비스 팩0, 1
    - Windows Server 2008 R2 64-bit 서비스 팩0, 1
    - Windows Server 2008 R2 Itanium 서비스 팩0, 1
    - Windows8 32-bit
    - Windows8 64-bit
    - Windows Server 2012
    - Windows RT
  • 영향 받지 않는 소프트웨어
    - Windows Server 2008 서비스 팩2 (서버코어 설치)
    - Windows Server 2008 64-bit 서비스 팩2 (서버코어 설치)
    - Windows Server 2008 R2 64-bit 서비스 팩0, 1 (서버코어 설치)
    - Windows Server 2012 (서버코어 설치)

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트

 

[MS12-076] Excel에서 발생하는 취약점으로 인한 원격코드 실행 문제

 

영향

  • 공격자가 영향 받는 시스템에 대해 완전한 권한 획득

설명

  • 사용자가 특수하게 제작된 엑셀 파일을 열람할 경우, 원격코드가 실행될 수 있는 취약점이 존재
  • 관련취약점 :
    - Excel SerAuxErrBar Heap Overflow Vulnerability (CVE-2012-1885)
    - Excel Memory Corruption Vulnerability – (CVE-2012-1886)
    - Excel SST Invalid Length Use After Free Vulnerability – (CVE-2012-1887)
    - Excel Stack Overflow Vulnerability – (CVE-2012-2543)
  • 영향 : 원격코드 실행
  • 중요도 : 중요

해당시스템

  • 영향 받는 소프트웨어
    - Microsoft Office 2003 서비스 팩 3
    - Microsoft Office 2007 서비스 팩 2, 3
    - Microsoft Office 2010 서비스팩1(32비트 에디션)
    - Microsoft Office 2010 서비스팩1(64비트 에디션)
    - Mac환경에서 동작하는 Microsoft Office 2008
    - Mac2011 환경에서 동작하는 Microsoft Office
    - Microsoft Excel Viewer 
    - Microsoft Office Compatibility Pack 서비스 팩 2, 3
  • 영향 받지 않는 소프트웨어
    - Microsoft Excel Web App 2010 서비스 팩 1
    - Microsoft Excel 2013(32비트 에디션)
    - Microsoft Excel 2013(64비트 에디션)
    - Microsoft Excel 2013 RT
    - Microsoft Excel Web App 2013
    - Microsoft Office SharePoint Server 2007 서비스 팩 2, 3 (32비트 에디션)환경에서 동작하는 엑셀 서비스
    - Microsoft Office SharePoint Server 2007 서비스 팩 2, 3 (64비트 에디션)환경에서 동작하는 엑셀 서비스
    - Microsoft Office SharePoint Server 2010 서비스 팩 1 환경에서 동작하는 엑셀 서비스

해결책

  • 해당 시스템에 대한 마이크로소프트사의 취약점 패치 적용

참조사이트




원문출처 : http://www.krcert.or.kr/kor/data/secNoticeView.jsp?p_bulletin_writing_sequence=1603
Tag List

서비스 링크

X
Login

브라우저를 닫더라도 로그인이 계속 유지될 수 있습니다. 로그인 유지 기능을 사용할 경우 다음 접속부터는 로그인을 하실 필요가 없습니다. 단, 게임방, 학교 등 공공장소에서 이용 시 개인정보가 유출될 수 있으니 꼭 로그아웃을 해주세요.

아이디가 없으신 분은

회원가입 후 이용하실 수 있습니다.

X